VKontalte announced "Your browser is out of date"

Modified on Mon, 19 Dec 2022 at 05:22 PM

Problem Description 

If you have been using the SNH for a long time, you may receive the following message when you open or create a new VK case:

our browser is out of date

This may cause VK to work slowly or experience errors. For speed and stability, we recommend you install the latest version of one of the following browsers


Cause of the problem 

The VKontakte website checks the version of the Internet browser used to ensure website compatibility. If the browser version is too old, there is a risk that the website will not work properly. Therefore, this message is displayed and further use of VK is prevented. The SNH uses the Chromium Embedded Browser as its internal browser. This browser component is updated at regular intervals as part of a software update of the SNH software. VK performs the browser version check based on the current user agent. This user agent is not automatically adjusted with an SNH update for various reasons. Therefore, the message issued by VK does not mean that the browser is behaving, but only that the browser is pretending to be outdated. 


You can display the browser agent used by the SNH:     

  1. Start the SNH     
  2. Main menu "File" -> "Options"     
  3. Select the "System" tab


 

Solution

For security reasons, the user agent cannot be adjusted via the program interface, and must be changed manually.  

  1. Close the SNH  
  2. Go to the SNH application directory:  
    c:\Users\%USERNAME%\AppData\Roaming\SocialNetworkHarvester  
  3. Open the config.ini file in a text editor 
  4. In the [system] section, you can manually adjust the useragent entry. A list of current user agents can be found here. Please note that we only run our software tests with the standard Firefox and Chrome user agents. Exceptional user agents, or user agents from mobile devices, may result in unanticipated backup results.  
  5. Save the text file and restart the SNH.

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